Computerwissenschaften

So erkennen Sie, welche Version von PHP Sie haben

Wenn Sie etwas nicht zum Laufen bringen können und glauben, es könnte daran liegen, dass Sie die falsche Version von PHP haben. gibt es eine wirklich einfache Möglichkeit, die aktuelle Version zu überprüfen.

Verschiedene Versionen von PHP haben möglicherweise unterschiedliche Standardeinstellungen und bei neueren Versionen möglicherweise neue Funktionen.

Wenn ein PHP-Tutorial Anweisungen für eine bestimmte Version von PHP enthält, ist es wichtig zu verstehen, wie Sie die von Ihnen installierte Version überprüfen.

 

So überprüfen Sie die PHP-Version

Wenn Sie eine einfache PHP-Datei ausführen, erfahren Sie nicht nur Ihre PHP-Version, sondern auch eine Fülle von Informationen zu all Ihren PHP-Einstellungen. Fügen Sie einfach diese einzelne Zeile PHP-Code in eine leere Textdatei ein und öffnen Sie sie auf dem Server:

<? php phpinfo ()?>

Im Folgenden erfahren Sie, wie Sie die lokal installierte Version von PHP überprüfen. Sie können dies in der Eingabeaufforderung unter Windows oder Terminal für Linux / macOS ausführen.

php -v

Hier ist eine Beispielausgabe:

PHP 5.6.35 (cli) (erstellt: 29. März 2018, 14:27:15 Uhr) 
Copyright (c) 1997-2016 Die PHP Group 
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies

 

Wird die PHP-Version in Windows nicht angezeigt?

Da Sie PHP tatsächlich auf Ihrem Webserver ausführen. wird die PHP-Version am häufigsten nicht angezeigt, wenn der Pfad zu PHP nicht mit Windows eingerichtet wurde.

Möglicherweise wird der Fehler folgendermaßen angezeigt, wenn die richtige Umgebungsvariable nicht konfiguriert ist:

'php.exe' wird nicht als interner oder externer Befehl, bedienbares Programm oder Batchdatei erkannt.

Geben Sie in einer Eingabeaufforderung den folgenden Befehl ein, wobei der Pfad nach „C:“ der Pfad zu PHP ist (Ihr Pfad kann unterschiedlich sein):

setze PATH =% PATH%; C: \ php \ php.exe

Similar Posts

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.